Back to overview
Degraded
SSO Microsoft is unavailable
Jan 30, 2026 at 01:04am UTC
Affected services
core.teamova.net
app.teamova.net
Resolved
Jan 30, 2026 at 02:47am UTC
SSO Microsoft is now available, under review but you can use it
Affected services
Created
Jan 30, 2026 at 01:04am UTC
SSO Microsoft is unavailable. Teamova need to be validated by Microsoft to provide this service
Affected services